Jump to content

phpMyAdmin-telepítése


rename
 Share

Recommended Posts

rename

Hali!

 

Segítséget szeretnék kérni phpmyadmin telepítéshez. Addig megvan, hogy másoljam be a weboldalak közé a mappát, telepítéshez pedig ott van a script/setup.php, ami szerintem az egy nagy hülyeség. Szóval, valami értelmes config beállítás kellene. Sajnos a neten nem találni hozzá. Apache, sql, php kismillió oldalon ki van vesézve, de a phpmyadminról valahogy mindenki megfeledkezik. :)

 

config.inc.php-ba kell pár módosítást végre hajtani , de akkor se lát semmit. :S

 

$cfg['Servers'][$i]['auth_type'] = 'cookie';
/* Server parameters */
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
/* Select mysqli if your server has it */
$cfg['Servers'][$i]['extension'] = 'mysql';
/* User for advanced features */
// $cfg['Servers'][$i]['controluser'] = 'username';
// $cfg['Servers'][$i]['controlpass'] = 'password';

Link to comment
Share on other sites

payskin

Csinálj egy ilyen config.inc.php-t

 

<?php
$i=1;
$cfg['PmaAbsoluteUri'] = 'http://localhost/akarmi/'; // a pMA elérési útja
$cfg['Servers'][$i]['host'] = 'localhost'; // a MySQL elérési útja
$cfg['Servers'][$i]['auth_type'] = 'config'; 
$cfg['Servers'][$i]['user'] = 'geza'; // felhasználónév
$cfg['Servers'][$i]['password'] = 'pogacsa'; // jelszó
$cfg['blowfish_secret'] = ''; 
?>

Link to comment
Share on other sites

rename

Megcsináltam , de akkor is ezt a hiba üzenetet kapom:

 

phpMyAdmin - Hiba nem tudtam bet?ni a mysql kiterjeszt鳴,<br />ellenőrizze a PHP konfigurᣩ Dokumentᣩ>

Link to comment
Share on other sites

payskin

Nem mondod, hogy ilyen kafa kínai karakteres hibaüzeneteket ír ki! Wow! :o

 

Egyébként a phpinfo() oldalon betöltődik a mysql vagy mysqli kiterjesztés? Mert ha nem, akkor már valahol hamarabb szúrtad el a dolgot.

 

Egy mezőt egyébként kifelejtettem, lehet, hogy emiatt van:

 

$cfg['Servers'][$i]['extension']     = 'mysqli';    // The php MySQL extension to use ('mysql' or 'mysqli')

Link to comment
Share on other sites

rename

Beírtam ezt is, de még mindig ugyan az a hiba. Nem kínai jelet kapok hanem egy négyzetet, csak a fórum hibásan jeleníti meg.

Edited by Gereby
Link to comment
Share on other sites

Gereby

Milyen szerveren fut a dolog?

Link to comment
Share on other sites

rename

win2003

 

apache 2.2.8

php 5.2.5

sql 5.0.51a

phpmyadmin 2.10

Link to comment
Share on other sites

rename

lekértem a phpinfot a következõt vettem észre

 

Loaded Configuration File (none)

 

Itt php.ini fájlnak kellene lennie , 2X újratelepítettem mindent még akkor is ezt írja szóval passz :)

Link to comment
Share on other sites

payskin

Látod ez az a pont, ahol részemről is passz. A telepítési leírás jó, csak követni kell a lépéseket, helyetted nem tudom megcsinálni... :hááát: Szóval ezen a helyzeten egyedül te tudsz változtatni.

Link to comment
Share on other sites

rename

Követtem a lépéseket , most már 3X telepítettem újra de még mindig rossz

Link to comment
Share on other sites

rename

Na, senki sem tud segíteni? :(

Link to comment
Share on other sites

payskin

Miben?

Link to comment
Share on other sites

rename

Miért nem indul el rendesen? A leírásodban a régebbi progik szerepelnek, szóval azokkal nem tudtam feltelepíteni, hanem az újabb verziókkal. Nem lehet, hogy itt máshogy kell konfigurálni?

Link to comment
Share on other sites

payskin

Írd meg a verziókat, megnézem.

Link to comment
Share on other sites

rename

win2003

 

apache 2.2.8

php 5.2.5

sql 5.0.51a

phpmyadmin 2.10

Link to comment
Share on other sites

payskin

Apache 2.2.8 + PHP 5.2.5 - Csak a leírásnak a képein rohantam végig -- működik. :hááát:

 

IPB kép

Link to comment
Share on other sites

rename

Lehetetlen, akkor nálam miért nem megy? Pedig mindent ugyanúgy csináltam mint te.

Link to comment
Share on other sites

payskin

Csináld meg ugyanazokat a képeket a te rendszeredrõl. Hátha azokból kiderül. De egyébként fogalmam nincs.

Link to comment
Share on other sites

  • 1 month later...
rename

Ma volt egy kis időm újra nekiálltam és elsőre sikerült minden. :D Viszont eggy valamire nem jöttem rá: a phpmyadminba való belépéskor jelszót kérjen a rendszer , mert a konfigoddal egyből beenged ez meg nem a legjobb megoldás.

---

Na, már megoldottam ezt a problémát is.

Link to comment
Share on other sites

payskin

Lám, lám, lám! :)

 

A phpMyAdminos aggodalmadat nem értem: a saját otthoni gépemen, ahol az Apache nincs kiengedve a netre, tehát egy zárt fejlesztőkörnyezetben miért kéne nekem minden alkalommal jelszót beírnom, hogy hozzáférjek a saját adatbázisaimhoz? :hááát: Ha az Apache ki volna engedve a netre és a phpMyAdmin látszódna "kívülről", úgy természeteen egész más a helyzet.

Link to comment
Share on other sites

  • 3 months later...
evikoko

Azt hiszem sokak nevében írhatom: hálával tartozunk Balázsnak a kiváló Apache-Php-MySql telepítés részletes leírásáért!

Most már csak a phpMyAdmin beállítása, az ami külön részletekben lelhetõ fel itt-ott.

Így egy kissé homályos, mit hová kell tenni.

 

Elõre is köszönettel, ha ez is oly alapossággal le volna itt vezetve

 

Link to comment
Share on other sites

payskin

Ööö... :huh: ... ennek a témának az elsõ néhány hozzászólása nem segít?

Link to comment
Share on other sites

  • 5 months later...
Gabicupulu

Valaki tudna segíteni? Phpmyadmin telepítés! Feltelepítettem, mindent konfigoltam, és amikor elindítom kér egy felhasználó nevet és egy jelszót. De ami a mysql felhasználót és jelszavamat nem fogadja el.

Link to comment
Share on other sites

payskin

Mit jelent az, hogy mindent felkonfigoltál? Mert elvileg pont annyit kell konfigolni rajta, hogy meg kell adni a MySQL-eléréshez a nevet meg a jelszót.

 

/**
* Server(s) configuration
*/
$i = 0;
// The $cfg['Servers'] array starts with $cfg['Servers'][1].  Do not use
// $cfg['Servers'][0]. You can disable a server config entry by setting host
// to ''. If you want more than one server, just copy following section
// (including $i incrementation) serveral times. There is no need to define
// full server array, just define values you need to change.
$i++;
$cfg['Servers'][$i]['host']          = 'localhost'; // MySQL hostname or IP address
$cfg['Servers'][$i]['extension']     = 'mysqli';    // The php MySQL extension to use ('mysql' or 'mysqli')
$cfg['Servers'][$i]['auth_type']     = 'config';    // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user']          = 'root';      // MySQL user
$cfg['Servers'][$i]['password']      = 'mukakotekercs';  // MySQL password (only needed
?>

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...