Jump to content
GSForum - Segélyvonal

Namo Webeditor Flash button kontra frame


fazsolt

Recommended Posts

fazsolt

Sziasztok!

A következõ gondom van:

 

Namo Webeditor 6 programmal keretes weboldalt létrehozva, majd, egyik keretben menüt létrehozva, és linkeket elhelyezve a következõ történik.

 

Célnak be van állítva egy másik keret, ennek ellenére a hivatkozás nem ott jelenik meg.

IE új ablakot nyit, Firefox új fület.

Ugyanakkor van olyan gép, ahol mûködik IE alatt, és van olyan is, ahol Firefox alatt is.

A gépek között vannak egyformák is és különbözõek is.

 

A hiba nem jelentkezik akkor, ha a link szöveg, kép, csak akkor, ha Flash gomb.

 

Azokat a fájlokat, amik mûködnek az egyik gépen, átmásolva egy olyan gépre, amin nem megy, nem megy ez sem. (Érthetõ?)

 

Beillesztem a kódot, hátha mond valakinek valamit:

 

<html>

 

<head>

<title>No title</title>

<meta name="generator" content="Namo WebEditor v6.0">

<base target="detail"></head>

 

<body bgcolor="white" text="black" link="blue" vlink="purple" alink="red">

<p><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" namo_flashbutton width="100" height="44">

<param name="movie" value="012_btn_1.swf">

<param name="play" value="false">

<param name="loop" value="false">

<param name="quality" value="high">

<param name="WMode" value="Window">

<embed width="100" height="44" src="012_btn_1.swf" play="false" loop="false" quality="high" WMode="Window" pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"></embed></object></p>

</body>

 

</html>

Link to comment
Share on other sites

zsoltchelsea

Itt a falsh vágja el a dolgodat, ugyanis (ez nálam is elõfordult) a Flash-es gombok, amelyek séma alapján készülnek, azokban alapértelmezett ez a beállítás. Talán a WMode-nál a value értéket állítsd át a frame nevére.

Link to comment
Share on other sites

fazsolt

Kipróbáltam, de sajna nem.

Én valam beállításon gondolkodom, ami megzavarja a Namot.

De fogalmam sincs mi lehet??

 

Itt a falsh vágja el a dolgodat, ugyanis (ez nálam is elõfordult) a Flash-es gombok, amelyek séma alapján készülnek, azokban alapértelmezett ez a beállítás.

 

Ennek ellentmond az, hogy egyik gépen ok, a másikon nem.

Ha a jól mûködõt neten nézem, akkor minden ok, ha letöltöm, vagy átküldi a fájlokat akkor nem.

 

Link to comment
Share on other sites

zsoltchelsea

Akkor meg hagyd fennt a neten és kész. Inkább a feltöltött adatöokat küldd át annak, akinek szeretnéd.

Link to comment
Share on other sites

fazsolt

Akkor nem volt érthetõ.

Szal:

Suliban gyerekekkel csinálunk weblapot.

Egyik emberkének megy, a másiknak nem.

Otthon készítve szintén van akinek megy, van akinek nem.

Nekem spec régebben ment. Most nem megy.

Ha feltöltöm netre, akkor meg ugyanaz, ami itt helyben.

És ha egy olyan géprõl, ahol rendben mûködik átszedem a fájlokat egy olyan gépre, ahol nem megy, akkor a másik gépen helyesen mûködõ weblap nem mûködik jól itt.

 

Ebbõl gondolom, hogy nem a Namoval van feltehetõleg baj, hanem Valami más kavar be.

Link to comment
Share on other sites

zsoltchelsea

Azt nézd még meg, hogy a képek linkje mindenhol jó -e. Bár ennek sok köze nincs a problémádhoz. A böngészõ, amiben megnézitek IE vagy Mozilla? Egységes a verziószámuk?

Link to comment
Share on other sites

fazsolt

Minden ok, és próbáltuk IE-vel is, FIrefox 1.5-tel, és 2.0-val is. Független a dolog. Valami máson bukhat meg.

Link to comment
Share on other sites

zsoltchelsea

Nem próbáltad még törölni a netrõl jövõ ideiglenes fájlok törlését?

Link to comment
Share on other sites

fazsolt

Próbáltam.

Töröltem én már mindent.

Teljes Temp mappa, Internet Temporaty ...

Cookik, meg mindent, amit lehetett, akár IE, akár Mozilla esetén

Link to comment
Share on other sites

zsoltchelsea

Mivel csináltad a gombokat? Külön programmal vagy Namoval?

Link to comment
Share on other sites

fazsolt

Csináltam Namoval is, meg külön programmal is, semmi különbség

Link to comment
Share on other sites

zsoltchelsea

Annyit csinálj még meg, hogy a linknél, amire vonatkozik a gomb, így írd be:

target="keret_neve"

Ha így sem megy, akkor én kifújtam, és irány a Flash topic.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...