Jump to content
GSForum - Segélyvonal

phpMyAdmin


h.arpad

Recommended Posts

h.arpad

Sziasztok!

 

Feltelepítettem a gépemre egy Windows, Apache, MySQL, PHP szervert, és meglepõdve tapasztaltam, hogy a phpMyAdmin-t jelszó nélkül hozza be öcsém helyi hálózatba kötött gépe, méghozzá teljes jogosultsággal turkálhatok adatbázisomban. :S Mivel titkosítatlan WLAN van, ez nem jelent túl sok jót... Le kellett állítanom a MySQL szervert.

 

Meg tudnátok mondani mit kell tennem? Beállítottam a jelszót a 'root'-hoz a phpMyAdmin-ban, a böngészõ ezt mégsem kéri. Ld. screenshot az öcsém gépérõl.

 

A config.inc.php részelete:

 

/* Servers configuration */
$i = 0;

/* Server ARPAD (config:root) [1] */
$i++;
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '........';
$cfg['Servers'][$i]['verbose'] = 'ARPAD';
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = 'jelszo';
/* End of servers configuration */

$cfg['UploadDir'] = 'uploaded';
$cfg['SaveDir'] = 'saved';
$cfg['docSQLDir'] = 'docSQL_files';
$cfg['AllowAnywhereRecoding'] = true;
$cfg['DefaultCharset'] = 'iso-8859-1';
$cfg['RecodingEngine'] = 'iconv';
$cfg['IconvExtraParams'] = '//TRANSLIT';

Link to comment
Share on other sites

Kiskalóz

Nem a MySQL-ben kell felhasználó nevet és jelszót beállítani?

Link to comment
Share on other sites

h.arpad

A MySQL-ben is. Hát épp ez az! Telepítettem a MySQL Administrator-t is, és ott a root felhasználónévvel és a ugyanazzal a jelszóval tökéletesen hozzáférek a MySQL beállításokhoz. Egyéb ötlet?

Link to comment
Share on other sites

Kovács Dávid ( Davs )

Indítsd el a phpMyAdmin-t, katt a privileges(jogosultságok)-ra, hozz létre egy új felhasználót jelszóval, töröld a többit, fõleg ahol nincs jelszó megadva, és a phpMyAdmin config file-ból töröld ki a felhasználónevet és a jelszót, és ekkor majd kérni fogja mindíg!

Figyelem! Ajánlom, hogy várj, amíg valaki megerõsíti a módszeremet, mert a károkért felelõsséget nem vállalok! Lehet, hogy ezzel elrontasz mindent! Szóval vigyázz!!

Link to comment
Share on other sites

h.arpad

Mindent nem ronthatok el, mert az adatbázisokról van mentésem, a többi meg nem érdekel. Az a vicces, hogy a privileges-ben (ld. screenshot) minden stimmel... :hááát: Na jó, akkor takarítok egyet!

Link to comment
Share on other sites

Kovács Dávid ( Davs )

Akkor valóban nem tudom. Mi történik, ha a konfiból kiveszed a root-ot meg a jelszót? Mert akkor nem fog tudni belépni és lehet, hogy kérni fogja a felhasználó adatait.

Link to comment
Share on other sites

h.arpad

Megoldottam. Valami miatt a MySQL szerver nem fogadta el a korábbi root jelszót, és ez kavart be. Mostmár csak 'root' van a phpMyAdmin-ben ('localhost' és '%' hozzáférés), mind lejelszavazva; kéri is a jelszót, és el is fogadja. Nem tudom mi történt a MySQL-el, de csak az újratelepítés segített rajta. Megváltóztattam a hitelesítést is:

$cfg['Servers'][$i]['auth_type'] = 'cookie';

A 'controlluser' kell ilyenkor?

Link to comment
Share on other sites

Kovács Dávid ( Davs )

Ha megy, akkor szerintem ne bántsd!

A controlluser pedig nem véletlenül egy korlátozott user, aki CSAK olvasni tudja a táblákat?

$cfg['Servers'][$i]['controluser']   = '';          // MySQL control user settings
                                                    // (this user must have read-only
$cfg['Servers'][$i]['controlpass']   = '';          // access to the "mysql/user"
                                                    // and "mysql/db" tables).
                                                    // The controluser is also
                                                    // used for all relational
                                                    // features (pmadb)

 

Nekem nincs beállítva. Egyébként miért baj az, hogy localhoston valaki babrálja a phpMyAdmin-odat? Azt csak php teszteslésre használod, nem?

Vagy másik megoldás: ha nem nagyon ért az öcséd az XP-hez, akkor hozz létre egy partíciót, telepítsd fel oda a php+apache+MySQL+phpMyAdmin-t és a fiókjából pl a Tweak UI-al tüntesd el azt a partíciót(hogy õ ne lássa).

 

Vagy még egy sokkal jobb megoldás: Ha az XP-s fiókod jelszóval van védve, akkor gondolom más nem piszkálhatja a file-jaidat...Másold az apache htdocs vagy www könyvtárát (ahol a php file-jaid meg a phpMyAdmin van) pl. az asztalodra, az apache httpd.conf állományában a DocumentRoot-ot írd át C:\Documents and Settings\felhasználónév\Asztal\valami -re. Ezzel ha beírod, hogy localhost, akkor az asztalodon lévõ file-okat fogja megjeleníteni az apache.

Link to comment
Share on other sites

h.arpad

Nem az öcsémtől féltettem, de, mint említettem nem titkosított a hálózat és az ő gépéről én jelszó nélkül kaptam ALL PRIVILEGES jogosultságot. Ez az, ami nem volt túl biztonságos. Nemcsak tesztelésre használom a MySQL-t, hanem most az Access helyett is. Van pár tábla, amelyhez jó, ha nem fér hozzá rajtam kívül senki. (Regisztrációs adatok: nevek, telefonszámok, e-mail címek...) Egyébként a legnagyobb kárt az tudja tenni, aki nem ért hozzá. ;) Új partició csak csökkentené az elérhető szabad helyet a lemezen.

 

A probléma szerencsére megoldódott. :) (Az Apache-ot tudom konfigurálni, de itt most nem az volt a gond, azért a segítséget köszönöm.)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...