Jump to content
GSForum - Segélyvonal

Melyik kernelt használjam?


csutomi

Recommended Posts

csutomi

Sziasztok! Szeretnék feltenni egy új Linuxot a gépemre. A telepítésnél ki lehet választani, hogy melyik kernellel kerüljön fel a Linux. Van hozzá egy 2.4-es és egy 2.6-os, de ez utóbbi csak béta verziós. Az lenne a kérdésem, hogy mennyire kockázatos egy béta verziós kernelt feltenni? Esetleg valaki használ ilyet?

Link to comment
Share on other sites

ProFiler

Sosem voltak problémáim a bétás kernelekkel. Igazából késõbb is frissítheted, ha valami nem tetszene - tehát szerintem nyugodtan tedd fel a legfrissebbet.

 

Ciao.

Link to comment
Share on other sites

csutomi

Köszi :) Egyébként frissíteni mennyire bonyolult, ha mégis arra kerülne sor? (Ha jól tudom, akkor azok a béta verziósok, amelyeknek a verziószámban (azt hiszem) a harmadik tagjuk páratlan.)

Link to comment
Share on other sites

ProFiler

Húha, a mennyire bonyolult az attól függ (nekem) a legjobban, hogy milyen disztribúcióról van szó. Azt tudom, hogy a SuSE-ban nem egyszerû, de megoldható. A többirõl rosszabbakat hallottam.

 

Ciao.

Link to comment
Share on other sites

Greene

A 2.4-es kernel van vagy 5 éves. A 2.6-os már élbõl nem béta, hanem használható verzió. Egy kis testing meg belefér.

Link to comment
Share on other sites

  • 2 weeks later...
csutomi

Kipróbáltam egy bétát a 2.6-osból. Hát az egeret és az integrált hangkártyát nem ismerte fel, úgyhogy hagytam. Viszont sikerült annyit ügyeskedni, hogy a 2.4-esbõl egy olyan van fenn, ami ugyan mindent felismer, csak az a probléma, hogy kikapcsoláskor nekem kell a gombot nyomkorászni: Vagyis szépen leáll a rendszer, leállítja a merevlemezt is, de a ventillátor és a többi még megy, ezért a gombbal kell kikapcsolni. Lehet, hogy hülye kérdés, de nem árt ez a gépnek?

 

Link to comment
Share on other sites

aty

Mégis milyen disztribúció ez?

Link to comment
Share on other sites

csutomi

Slackware 10.2

Link to comment
Share on other sites

aty

Valahogy éreztem.

 

2.4es kernel hibája: acpid biztosan fut? Ha nem /etc/rc.d/rc.acpid kapjon futási jogot. Hogy ártana a gépnek, nem értem. Ha készenléti állapotba kerül a gép akkor is leáll a merevlemez. Nincs itt semmi gond, csak az acpi támogatás nem mûködik az említettek miatt talán.

 

Továbbá a 2.6os korántsem béta, Pat egyszerûen nem akarja a Slackwareben alkalmazni, ezért van évek óta csak a testing ágban, egyes hírek szerint a 11.0ba se fog bekerülni.

 

2.6os kernel:

Milyen típusú egér, hangkártya?

A leírás alapján raktad fel? Initrd van? rc.hotplugnak van futási joga? Udev fennvan? rc.udevnek van futási joga?

Bocs, de semmi konkrétumot nem írtál.

Link to comment
Share on other sites

csutomi

Most elvileg, amiket leírtál, azoknal van futási joguk (755).

 

Az egér már mûködik (újrafordítottam a kernelt és most az rendben van). Az Udev mire való és hogyan kell használni?

 

Hangkártya még mindig nem jó, sajnos, mivel az alaplapba integrálták nincs róla semmi leírásom, azt sem tudom, hogy eszik-e vagy isszák. Csak ennyit tudtam meg róla: Multimedia audio controller: C-Media Electronics Inc. CM8738 (rev b2) És azzal bombáz a KDE, hogy nem lesz hang, mert nincs olyan eszköz, hogy /dev/dsp. Valami akkor kimaradt a kernelbõl a fordítás során, vagy ez más probléma? (2.4-essel tökéletesen mûködött)

Link to comment
Share on other sites

aty

Udev dinamikus eszközfájlokat hoz létre devfs helyett, 2.6 széria alatt már ezt illik használni.

 

Hangkártya:

nos Slackware alatt az a hagyomány hogy külön csomagban van az alsa-driver és a kernel csomagban nincs hangtámogatás.

Most pontosan milyen kernelt használsz? Ha kézzel fordítottat, akkor csak rajtad múlik hogy van-e hang vagy nincs, ugyanis csak be kell jelölni a megfelelõ modulokat a hangeszközöknél.

 

Ha azonban mégis csomagból felrakottat használnál, akkor a README-t követve(!) rakd fel a 2.6os szériát, és a testing könyvtárban találsz még egy ehhez passzoló alsa-driver csomagot, azt is rakd fel.

Link to comment
Share on other sites

Kovács Dávid ( Davs )

Slackware Linux telepítésénél bare.acpi kernelt kell kiválasztani (tapasztalat)!

Link to comment
Share on other sites

aty

Nah igen :)

Link to comment
Share on other sites

csutomi

OK, megvan már. A gond az volt, hogy nem fordítottam bele a kernelbe a saját hangkártya drájveremet. Ez mûködik. (Még elsõ indításnál le kellett futtatni az alsaconfig-ot is)

 

Viszont van mégegy gond: a 2.4-es kernelhez volt az iptables, amit a guarddog nevezetû tûzfal program használt. Most viszont az új 2.6-os kernelben valami más van helyette. Így akkor most nincs tûzfalam? Lehet használni egyáltalán 2.6-os kernellel az iptables-t? Vagy mi az, ami helyette van?

Link to comment
Share on other sites

aty

Van iptables a 2.6os ágban is, kernelconfigban keresd meg, talán netfilter kulcsszó alatt bújnak meg a moduljai.

 

menuconfigban: Networking -> Networkign options -> Network packet filtering és itt beállíthatod a szükséges modulokat.

Link to comment
Share on other sites

csutomi

Beletettem az itt található dolgokat, de még mindig nem jó. Ezt írja a guarddog:

FATAL: Module ip_tables not found.

iptables v1.3.3: can't initialize iptables table `filter': iptables who? (do you need to insmod?)

Perhaps iptables or your kernel needs to be upgraded.

Finished.

Mi lehet a gond?
Link to comment
Share on other sites

aty

Networking -> Networkign options -> Network packet filtering -> IP Netfilter confi. -> IP tables support? E mögött is van M?

Link to comment
Share on other sites

csutomi

OK, benne van már a kernelben. Most a következõ a gond: Ha elindítom a gépet (2.6-os kernellel), alapból van net, viszont a guarddog-ot, ha lefuttatom, a következõt írja ki:

Using iptables.

Resetting firewall rules.

Loading kernel modules.

Setting kernel parameters.

Configuring firewall rules.

iptables: No chain/target/match by that name

iptables: No chain/target/match by that name

iptables: No chain/target/match by that name

iptables: No chain/target/match by that name

És utána elmegy a net, mintha nem is lett volna. :Sír:

Link to comment
Share on other sites

aty

Milyen szabályokat akar betölteni a Guarddog? Csak van neki egy configja vagy egy scriptje amivel ellenõrizhetõ lenne.

 

De különben egyszerûbb ha felrakod a hivatalos 2.6os kernelt csomagból, és a többi szükséges összetevõt is.

Link to comment
Share on other sites

csutomi

Gondolom úgy érted, hogy a CD-ről tegyem fel a test26.i-t. És miket kéne még hozzá felrakni? Próbáltam már, finoman szólva nem volt tökéletes... Egyébként kell az a tűzfal szerinted? Mármint a guarddog, vagy a linux kernel alapból elég biztonságot nyújt az iptables-en keresztül?

Link to comment
Share on other sites

aty

10.2 cdn van egy testing könyvtár:

/testing/packages/linux-2.6.13

Itt az összes csomagot telepítsd.

Késõbbi hibák elkerülése végett a gcct is frissítsd.

/testing/packages/gcc-3.4.4

Kell még az udev csomag is:

http://www.linuxpackages.net/download.php?id=7731

Szerintem ennyibõl megáll.

Ha gondod van még az egérrel akkor valamelyik initscriptben egy modprobe psmouse sort kell elhelyezni.

 

Link to comment
Share on other sites

csutomi

megvan, hogy mitõl van az üzenet, íme:

bash-3.00# iptables -A f1to0 -p tcp --sport 1024:5999 --dport 80:80 -m state

--state NEW -j ACCEPT

iptables: No chain/target/match by that name

bash-3.00#

Ez mitõl van? (Egyébként, ha jól tudom, akkor ez engedélyezné a http protokol használatát a 80-as porton keresztül, tehát magyarul "lenne netem".)
Link to comment
Share on other sites

aty

f1to0 - Ez miféle lánc?

Link to comment
Share on other sites

  • 3 months later...
csutomi

A kernel.org-on fenn vannak a kernelek és vannak ott olyan fájlok is, amik úgy kezdõdnek, hogy patch-... (Olyan 5 mega körül vannak) Ezeket hogyan lehet használni? Vagy mit kell velük csinálni, hogy használni lehessen õket?

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...