Jump to content
GSForum - Segélyvonal

WAP354 Bridge/Router alakítás


SyncMaster
 Share

Recommended Posts

SyncMaster

Sziasztok!

 

A tulajdonomba került egy WAP354-es Bridge/Router eszköz. Ez valamikor a Dunaweb Kft tulajdona volt. A lényeg! Az eszközön a cég saját firmwareje fut, valami házilag összedobott. Viszont én szeretném rárakni a gyárit. A gyári meg is van de nem tudom ráfrissíteni. Kiválasztom a firmware-t rányomok hogy Frissítés és nem csinál semmit.

 

Tudna ebben valaki segíteni? Itt egy kép az eszközrõl, hátha segít valamit.

 

Kép az eszközrõl

 

Köszönöm a segítségeteket!

Link to comment
Share on other sites

[OP]Destroy-man

Az egyedi oprendszerből kiindulva valószínűleg elérhető a router konzolból is, mint pl. Putty. Egyedi oprendszert innen szoktak telepíteni, és visszaállítani is.

 

Ez ugyan a Fonera routerek leírása, de működnie kell a WAP354-en is, amennyiben linux alapú a router (gondolom az):

http://trac.fonosfera.org/fon-ng/wiki/sshflash

Link to comment
Share on other sites

SyncMaster

Igen Linux alapú a rajta fut.Igen el tudom érni telnet-el viszont SSH-n nem érem el. Az baj ha csak telnet-el tudok rámenni?

Link to comment
Share on other sites

KGigi

Ameddig ki tudod adni az utasításokat, teljesen mindegy.

Link to comment
Share on other sites

SyncMaster

Nincs valami egyszerûbb módja ennek? A wget-re ismeretlen parancsot ír... :(

Link to comment
Share on other sites

KGigi

Akkor baj :D Viszont ha van telneted, elvileg minden további nélkül fel tudod telepíteni az SSH szervert. Általában openssh-server, vagy valami hasonló néven fut.

Link to comment
Share on other sites

SyncMaster

Köszönöm hogy kinevetel. Annyira jutottam vele hogy találtam egy oldalt Oldal linkje és ez alapján csináltam volna. Csak elõtte csináltam nála egy rescue és reboot parancsot amit már máskor is csináltam.

Most ott tartok hogy a router nem válaszol. Se http se ftp szolgáltatás nem fut.

Telnet fut rajta de amivel eddig beléptem rá név és jelszó be sem enged. Mit lehet még ilyenkor tenni vele? A kukát kivéve.

Link to comment
Share on other sites

[OP]Destroy-man

Minden routeren van egy reset gomb. Használd bátran. A kérdés csak az, hogy ennél a modellnél hogy működik, ugyanis ahány router annyi resetelési módszer. Ha sikerül resetelni, akkor visszaáll minden a default értékekre, így a felhasználónév és a jelszó is.

És akkor kezdhetsz mindent az elejéről.

 

Alapértelmezésben admin a felhasználónév, jelszó pedig nincs. A kérdés, hogy a módosított firmwareben ezt megváltoztatták-e vagy nem, de ezt nem illik ott sem.

Link to comment
Share on other sites

SyncMaster

Csak a rescue parancs is ugyanezt csinálja tudtommal mint a reset gomb. Bár már kipróbáltam a reset gombot és ugyanúgy nem fogadja el a nevet és a jelszót. Annyit tudok még hogy ping-re reagál és telnet-re de másra nem. Így hogyan tudnám az eredeti szoftverét rátölteni?

Próbáltam a tftp-vel de sorozatban idõtúllépést kapok. IP címet ad de az 169-el kezdõdik. Elõtte az alap IP címe 10.0.0.1 volt. A ping erre a 10-es IP-re reagál. Viszont olvastam valamit arról hogy boot elején várakozik pár másodpercet ahol várhatja az új firmware feltöltését is. Nincs itt valami router guru? :) Nem nagyon szeretnék tõle megválni ugyanis kétsávos a kütyüke és ez pont megfelelne itthonra.

Link to comment
Share on other sites

[OP]Destroy-man

A gyári leírás szerint az alapértelmezett beállítások a következőek:

IP: 192.168.1.254

Felhasználónév: admin

Jelszó: nincs

 

Próbáld meg ezzel.

 

Ha minden kötél szakad, csináltass egy teljes hálózati szkennelést az összes elérhető IP-re, hogy megtudd a valódi IP címét a routernek. Ez jó darabig eltart. Viszont a routernek tuti semmi baja, ilyennel nem lehet elrontani. Maximum annyit tudok elképzelni, hogy a Dunawebesek ezeket a default értékeket is átírták az oprendszerben, de akkor sokat nem fogunk tudni mi itt segíteni ezzel kapcsolatban, a login adatokat csak ők fogják tudni megadni.

 

Szerk.:

Keresgéltem neked még 1 pár infót. Több helyen is azt írják, hogy DHCP-vel nincs kapcsolat, tehát fix IP-t kell adnod a gépednek router reset után:

A géped IP címe legyen: 192.168.1.xxx (a végére a 10-et illetve a 211-et ajánlják). Kérdés, hogy ez számít-e.

Átjáró: 255.255.255.0

DNS: 192.168.1.1

 

Utána webböngészőből nyisd meg a 192.168.1.254-es ip címet. Ha kér jelszót, akkor már félsiker.

Próbálj meg belépni. A hivatalos dokumentum szerint nincs jelszó, de most találkoztam olyan infókkal is, hogy admin a jelszó is.

Link to comment
Share on other sites

SkyBird

Itt valóban IP cím probléma lesz.

A reset ezt is visszaállította defaultra. A 10.0.0.1 valószínûleg nem alapértelmezett volt.

A 169 kezdetû IP-ket nem a router adja, hanem a Windows. Pont az van ilyenkor, hogy az adapter nem kap IP címet valamiért a DHCP szervertõl, illetve az nem mûködik.

A PC-n is úgy kell állítsd az IP címet fixen, hogy lássa, egy hálózaton legyen az [OP]Destroy-man által írt default IP címû routerrel a módosításhoz.

Link to comment
Share on other sites

SyncMaster

Szóval. Mivel az eredeti firmwaret nem tudtam rátolni így aztán a fent megadott adatokat még nem volt idõm kipróbálni. De remélem majd sikerülni fog. A másik [OP]Destroy-man írt egy hálózati szekenelõ programot. Na most jó lenne ha tudna egy nevet is hozzá mondani amit már próbált és tutira mûködik.

 

Köszönöm a fáradozásotokat!

Link to comment
Share on other sites

SkyBird

Pl. ez, ami a MAC címeket is mutatja. Colasoft MAC Scanner

De IP scannerre is számos találatod lesz a neten.

Link to comment
Share on other sites

KGigi

Nem kell ehhez külön program, elég megpingelni az alhálózat broadcast címét. Ha például a hálózat 192.168.1.x, az alhálózati maszk pedig 255.255.255.0, akkor a 192.168.1.255-öt.

Link to comment
Share on other sites

[OP]Destroy-man

Én kipróbáltam ezt a pingelõs megoldást, de az nem mûködik.

Ip scannelõ programot meg azért nem írtam név szerint, mert a google úgyis ad egy raklappal, mindegyik jól mûködik.

Link to comment
Share on other sites

KGigi

Mûködnie kellene. Nem tudom kipróbálni, mert most nincs kéznél Windowsom, de a Linuxos alternatívája szépen megy.

Link to comment
Share on other sites

arpsoft

A Windows ping-je nem kezeli a broadcast címeket. :)

Link to comment
Share on other sites

KGigi

Pff, köszi, jó tudni. Linuxos oldalon írták, hogy mûködik :D

Link to comment
Share on other sites

SyncMaster

Nem jutottam elõrébb. Csak egy IP címen érhetõ el a kütyü a 10.0.0.1-en.

Viszont az feltûnt ha telnet-el rá akarok menni ugyebár a Login elõtt van egy ilyen <> és közötte hogy hova akarsz belépni. Nos ennél most így néz ki:

<none> Login:

 

és régen elõtte

 

<#>Login:

 

Ez mit jelenthet?

Link to comment
Share on other sites

  • 2 months later...
SyncMaster

Sziasztok ismét!

 

Na szóval nem hagyott nyugodni a dolog. Feltelepítettem ma a BackTrack 5 Ubuntu alapú rendszert. Elindítottam az Nmap programot és hát nem sok érdekes dolgot adott.

Belinkelem az Nmap reportját. XML dokumentum de sajna a IE nem nyíitja meg csak TC-ben F3-mal lehet benne valamicskét olvasni.

 

http://p2p.ininet.hu/bridge/201301231933%20Intense%20scan%20on%2010.0.0.1.xml

 

http://p2p.ininet.hu/bridge/201301231935%20Slow%20comprehensive%20scan%20on%2010.0.0.1.xml

 

Utána a netről leszedtem egy 19,2MB-os jelszó állományt és betöltöttem a Hydra-ba hátha az segít. Alapból a nevet root -ra állítottam. De semmi.

Valaki esetleg tudna még segíteni hogy hogyan tudnám kideríteni a kütyü nevét és jelszavát?

Link to comment
Share on other sites

[OP]Destroy-man

Én 1 hete "halasztottam meg" a Foneramat (véletlenül sikerült ráflashelni egy olyan OpenWRT-t, ami nem ehhez a chipkészlethez készült. :P). Nálam a helyreállítási megoldás az volt, amit korábban fentebb is írtam, hogy fix IP-re kell állítani a gépet, viszont a routert is download módba kell tenni. Ha sikerül ezt megtenni, akkor már simán fel tudsz rá flashelni bármit, és helyre rakja saját magát.

Fonera esetén a download módot így lehet elérni: reset gomb nyomva tart, tápkábel beköt, 5-10 mp-ig még továbbra is nyomva tart a reset gomb, majd ha folyamatosan jelez az USB led, de nincs bekötve USB eszköz, akkor belépet a download módba. Ezen kívűl csak az 1-es portba lehet kábel, ami a PC-vel van összekötve, más kábel nem lehet bekötve.

Link to comment
Share on other sites

SyncMaster
Destroy-man' timestamp='1358982582' post='454280']

Fonera esetén a download módot így lehet elérni: reset gomb nyomva tart, tápkábel beköt, 5-10 mp-ig még továbbra is nyomva tart a reset gomb, majd ha folyamatosan jelez az USB led, de nincs bekötve USB eszköz, akkor belépet a download módba.

 

Miféle USB led? Ezen a routeren nincs USB bemenet. A többit értem amit írsz csak ezt nem. Vagy csak láma vagyok. Kifejtenéd melyik USB ledre gondoltál? :pislog:

 

http://produto.mercadolivre.com.br/MLB-451118685-ap-router-cliente-wireless-abocom-wap354-58ghz-24ghz-_JM

 

Itt az eredeti dobozában található meg de itt sincs rajta USB.

Link to comment
Share on other sites

[OP]Destroy-man

Én a saját Fonerámra gondoltam, azon van. Itt is kell valamiféle visszajelzésnek lenni, csak példaként írtam. Ha sikerül download módba rakni a készüléket, akkor onnantól már csak fel kell másolni a firmwaret, és helyre rakja magát a készülék.

Link to comment
Share on other sites

SyncMaster

Szóval :)

 

Ma játszadoztam vele kicsit. És be tudtam rá jelentkezni :oké: Telnet-en keresztül sikerült rámászni.

Nem mindegyik porton tudok rámászni de ez most mellékes. Az a lényeg hogy be tudok jelentkezni. FTP és HTTP nincs.

Megvan a gyári Firmware. Milyen programmal tudom a legegyszerűbben rátölteni? Tftp kilőve mert nincs FTP :(

 

Mi lenne ez az "ash"?

Mellékeltem egy képet is. Hátha segít valamit.

 

http://p2p.ininet.hu/bridge/ash.jpg

 

 

És ha rá van töltve magától újraindul vagy nekem még mit kell csinálni?

 

Köszönöm a kitartó segítségedet!

Link to comment
Share on other sites

[OP]Destroy-man

Én tftp-vel töltöttem fel.

Meg lehet próbálni scp-vel felmásolni: http://www.garron.me/linux/scp-linux-mac-command-windows-copy-files-over-ssh.html

Majd mtd-vel felírni:

mtd -r write /tmp/filename.img image

 

Ha ezzel megvagy, akkor magától újra kell indulnia, és onnan működnie kell. Ha 10 perc után se megy, vagy nem indul újra, akkor indítsd újra kézzel.

 

Bár TFtp-vel is menni kell, csak előbb fel kell telepíteni a TFtp-t a gépedre. A vezérlőpult/programok/Windows szolgáltatások telepítése... Menüben be tudok kapcsolni. Ha ezzel megvagy, akkor cmd-ből kiadod a parancsot (nem kell hozzá telnet, vagy putty):

tftp -i 10.0.0.1 PUT \path\of\the\image.bin

A cmd-t, rendszergazdaként indítsd, és akkor menni fog.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...