Jump to content
GSForum - Segélyvonal

.NET-keretrendszer


T_boy
 Share

Recommended Posts

T_boy

Sziasztok!

 

Sajnálom, hogy tudatlan vagyok. De mire is jók ezek a .NET-keretrendszerek? (Kerestem már Google-ban meg egyéb helyeken, de érdemleges válaszra nem találtam.)

 

Köszönöm!

 

Üdv.:

T_boy

Link to comment
Share on other sites

payskin

Ez egy programfejlesztési és futtatási keretrendszer. Akkor kell felraknod, ha olyan programot akarsz futtatni, ami .NET alatt készült. (Például nLite.) Ha nem használsz ilyen alkalmazásokat, nincs rá szükséged. Lásd még: Java. Ugyanez a történet.

Link to comment
Share on other sites

  • 2 years later...
Pjotr

.NET-keretrendszer telepítése Windows XP 32 bitre

Ha tisztában vagyunk azzal, hogy .NET-es alkalmazásokat használunk, és -- mondjuk -- újratelepítünk, akkor a keretrendszert minél hamarabb tegyük fel (pl. driverek után, programok, frissítések előtt).

  1. .NET-keretrendszer 3.5 SP1 (nem offline pakk, telepítés közben szükséges internetkapcsolat [~ 20 MB-ot tölt le])
  2. .NET-keretrendszer 4.0
  3. Frissítések: Windows (Microsoft) Update
Cleanup Tool .NET Framework Remover

 

FRISSÍTVE!

Edited by Pjotr
Link to comment
Share on other sites

KGigi

Ebben benne vannak a régiek is? Tudom, hogy manapság nem sok program használ mondjuk .NET 1.1-et (.NET 2.x-et talán több), de ha egyszer mégis kell, akkor csak pislog a felhasználó.

Link to comment
Share on other sites

Pjotr

A többi csomagot el kell felejteni. Ha felkerülnek a gépre, akkor furcsa dolgok történhetnek. Azért is frissítettem fel, mert a nyugdíjazni kívánt topikban volt akkora keverés vele, plusz linkelve volt egy Logout-os írás is róla még nagyobb káosszal, pff.

Ezeknek kell benne lennie:
  • v1.0.3705
  • v1.1.4322
  • v2.0.50727
  • v3.0
  • v3.5

Link to comment
Share on other sites

KGigi

Elvileg ha sorban teszi fel olyan módon, hogy 1.1, 1.1 javítások, 2.x, 2.x javítások, 3.5 SP1, akkor nem lehet baj. Az egész igazából már nem olyan érdekes, mert Vistától felfelé integrálva van az operációs rendszerve a .NET, de valószínûleg pont olyanok használnak még XP-t, akik sok régebbi programot is futtatnak.

Link to comment
Share on other sites

Pjotr

De még milyen baj lehet belõle! :igen: Az elõzõ hozzászólást kiegészítettem egy listával.

Link to comment
Share on other sites

KGigi

Aha, szóval akkor ha feltolom a 3.5-öst, akkor azok a programok, amik ezt az n fajta verziót használják, mind menni fognak? Király. :) Ez régen (mikor utoljára XP-t telepítettem :fütyül: ) nem volt így.

Link to comment
Share on other sites

[OP]Destroy-man

A .NET 3.0 (elvileg) tartalmazza a 2.0-át is. Legalábbis ha felrakod a 3.0-át nem engedi telepíteni a 2.0-át, mondván, hogy már fent van. :) Az 1.0-át és az 1.1-et viszont már nem tartalmazza!

Link to comment
Share on other sites

Csaba_#

Már elve az mekkora nagy baromság a Microsofttól, hogy az egyes .NET verziók felülrõl nem kompatibilisek egymással. :S

Link to comment
Share on other sites

Pjotr
A .NET 3.0 (elvileg) tartalmazza a 2.0-át is. Legalábbis ha felrakod a 3.0-át nem engedi telepíteni a 2.0-át, mondván, hogy már fent van. :) Az 1.0-át és az 1.1-et viszont már nem tartalmazza!

Olvass vissza! :dühös:

Link to comment
Share on other sites

Csaba_#

Nyugi, elolvastam ez egész topic-ot. De én inkább maradok a sorba telepítõs módszernél. A múltkor szívtam egy régebbi Catalyst-al (amivel egy Radeon 9200 miatt kellett kínlódnom), felraktam a 2.0-át és 3.0 -át 3.5 SP1-et, de mégis összefoschta magát a driver. Az 1.1 SP1-et meg már nem hagyta telepíteni, szóval kezdhettem az egészet elölrõl egy rahedli szemetet magam után hagyva. Szóval .NET =káosz^3. :S

Link to comment
Share on other sites

Pjotr

Tehát a múltkor sorrendben telepítetted, és nem ment? :P Most pont van nálam egy 9250-es kártyával szerelt gép, amire mondjuk a CCC-t nem tettem fel, de majd megnézem (.NET-et feltoltam rá).

Link to comment
Share on other sites

Csaba_#

Pont hogy nem, mert az 1.1 -et kihagytam (és mint később kiderült ez kellett annak a régi CCC-nek). De való igaz, a CCC nem ért meg egy agyvérzés közeli állapotot, elég lett volna simán driver, vagy inkább egy Omega. Általában nem bonyolítom, és csak a 2.0-át rakom fel, (fölöslegesen nem szemetelem tele a gépeket a különféle verzióival) az újabb CCC-k és az nLine meg ezzel is elboldogul. Szerencsére más .NET keretrendszert igénylő programot nem vagyok kénytelen használni.

Link to comment
Share on other sites

Pjotr

1.1 kell neki? :pislog:

Link to comment
Share on other sites

Csaba_#

Halvány lila gõzöm sincs, hogy mi kell neki. De miután felraktam az 1.1 SP1-et, utána mûködött.

Link to comment
Share on other sites

Pjotr

Na, nem indult el. Illetve fut, csak nem látni belõle semmit, nagy kalap szamóca. :P

Link to comment
Share on other sites

  • 3 months later...
Pjotr

.NET 4 elérhetõ, #3-ban linkelve. Telepíthetõ Vista-ra és 7-re is.

Link to comment
Share on other sites

KGigi

És mihez kell? :)

Link to comment
Share on other sites

Pjotr

VS2010 :fogatlan:

Link to comment
Share on other sites

[OP]Destroy-man

De az meg alapbol tartalmazza. :D

 

Egyébként Pjotr nem értek veled egyet a .NET telepítés menetével.

Elöször a .Net 1.1 SP1-et kell telepíteni, majd csak utána jöhet a 3.5, ugyanis az egyes szériát valami miatt kihagyták a magasabb verziókbol. Tapasztalatbol mondom. :)

De ha nagyon kötekedni akarsz, a telepítő megengedi, hogy utolag is felrakd a gépedre. :)

Link to comment
Share on other sites

Pjotr

Tudom, hogy nincs benne a 1.1, de nem igazán lehet olyan programmal találkozni, ami ezt igényelné (régi CCC-t kivéve). Egyébként teljesen érthető, miért hagyták ki. Az 1.x-es és a 2.0 teljesen eltérőek, míg a 2.0 felettiek csak a 2.0 bővítései. Ha megnézed Windows 7 alatt, hogy fent van-e az 1.x, láthatod, hogy a Microsoft is tesz rá.

Link to comment
Share on other sites

SkyBird

Az 1.1-et én sem teszem fel már jó ideje. Felesleges.

Link to comment
Share on other sites

mg820408

Sziasztok!

 

A 4-es .net-es keretrendszer még csak angolul elérhetõ, fel telepíthetem magyar xp-re? Válaszotokat elõre is köszönöm!

 

Üdv,

Gergõ

Link to comment
Share on other sites

SkyBird

Simán. Egyébként ékes magyarsággal fog kommunikálni veled a telepítõ.

Ettõl függetlenül az elõzõ verziókhoz adtak ki nyelvi csomagokat is, külön.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...