Jump to content
GSForum - Segélyvonal

MSI Starcam hiba - cannot create video capture filter


Aniko1111
 Share

Recommended Posts

Aniko1111

Új webcam driver telepítés után nem mûködik, a kezelõ capture progi a köv hibát adja:

Cannot create video capture filter.

 

Annyit már sikerült kiderítenem, hogy valami összeakadásról lehet szó (de nem biztos), többen is belebotlottak már ebbe a hibába (nem csak webcamnál, hanem videocamnál is), de megoldást sehol sem tudtak adni, csak a kérdés van árván a többi fórumon is.

 

Típus: MSI starcam Genie

windows xp

 

Az eszköz a windowsban megfelelõen van telepítve.

 

Gyártó oldalán nincs driver frissítés, csak az az egy van, ami a cd-n is volt.

 

Valaki tudna segíteni, hogy mi az a capture filter és mi lehet az oka annak, hogy ezt a kezelõ nem tudja létrehozni?

 

Köszönöm

Link to comment
Share on other sites

Jay

Töltsd le a Process Explorert, ezzel láthatod, ha valamivel össze van akadva.

 

Töröld le és telepítsd újra úgy, hogy nincs csatlakoztatva a webkamera.

Link to comment
Share on other sites

  • 4 weeks later...
tibitibi

Üdv!

 

Ugyanez a problémám van, és nagyon jó lenne ha megtalálnánk rá a megoldást.

Elõre mondom, hogy nem vagyok szakmabeli, nem értek hozzá hivatalból, csak azt tudom leírni amit eddig próbáltam és tapasztaltam a neten elolvasgatott hasonló problémamegoldó fórumok tanácsai alapján.

 

Mivel nem lehet tudni mi a hiba oka ezért az a biztos, ha leírom a körülményeket.

Vista 64-bit, VGA kártya - ATI Radeon HD 4670, screen - 1680x1050, kamera - MSI StarCam 370i

 

Annyit megtudtam, hogy valszleg nem függ attól, hogy milyen az oprendszer, mert XP 32-bit is produkál ilyeneket. A webcam, vagy videocam típusa sem valószínû, hogy fontos.

 

Az érdekes az, hogy a driver gond nélkül települ, a capture program viszont az említett hibaüzenettel indul, így bár az ablak nyitva marad semmilyen beállítási opció nem érhetõ el - értsd nincs benne, vagy nem aktív a menüsorban. A memóriában csücsülõ kamera detektáló/kezelõ modul ikonja át van húzva, mintha nem lenne bedugva a cam (jobbklikkre elõjõn egy Exit, tehát semmit nem lehet vele csinálni) Érdekes viszont, hogy a kamerába épített mikrofon jól mûködik. A skype elfogadja mikrofonnak, sõt érzékeli mint kamerát, de azt írja, hogy az eszközt egy másik alkalmazás használja.

Nálam semmilyen más alkalmazás nem foglalkozott a webcam-mel, vagy lehet, hogy nem találtam meg.

Jay által javasolt process explorer nem talált semmi ütközést, sem pedig más futó video alkalmazást.

 

A device manager szerint " az eszköz megfelelõen mûködik".

A gyártó lapjáról lehúzott legfrissebb driverrel is ugyanez van, tehát nem valószínû, h. a driver a gond.

 

A hiba tehát az én gépemben van.

Volt aki azt tanácsolta, hogy takarítsam ki a registry-t és minden jó lesz. Megtörtént az is. Nem lett yo!

 

Mi lehet az a video filter?

Nézzük mit ír a cam papírja? Image Capturing fejezet 6. pontban leírják, hogyan lehet kiválasztani a video capture filtert, de sajnos ez a sor nincs meg a kezelõprogi menüjében - persze mert az induláskor nem találta meg. Az elérhetõ legnagyobb felbontás SXGA: 1280x1024. Bár hülyeségnek tûnt, de nosza monitor felbontást átállítottam ... persze nem ez a gond.

 

Nincs a gépemen a megfelelõ filter? Azt olvastam, hogy a filterek a codec csomagokkal jönnek. A gépemre K-lite Codec Pack (Full) van felrakva, néztem a codec-eket, filtereket, de nekem nem mondott ez semmit, mert nem egy konkrét filtert hiányolt a webcam. Nosza azért lehúztam a netrõl a legfrissebb verziót és lecseréltem az egészet. Az install alatt bepikkeltem a delete broken codecs/filter opciót vagy valami ilyesmi neve van. No és akkor jött egy érdekesség: talált a K-lile 4.7-es csomag az install alatt/után azt hiszem 2 rossz filtert. Az egyik neve úgy kezdõdött, hogy MSI trallala akármi meg egy csomó szám, de sajnos voltam olyan hülye, - mert nem gondoltam, hogy esetleg fontos lesz - hogy nem nyomtam egy PrintScreent, ehelyett nyomtam egy Yes-t, aminek az lett az eredménye, hogy a filter (ami ezek szerint hibás volt, ha igaz) ment a kukába.

Persze codeccserékkel ugyanúgy nem oldódott meg a dolog.

Próbáltam még a Vista Codec Pack -el is hátha, de semmi. A 3 éve nem frissített Ace MegaPack 6.3-on gondolkodtam, de nem mertem megcsinálni.

 

Rácuppantam a netre, de semmit nem adott ki ilyen nevû filterrõl.

A codec csomagok content listájában szemezgettem, sehol semmi.

Ilyen MSI filterhez mégcsak hasonló dolgot sem lehet találni a neten, még a Microsoft szeméthegyébe is beleturkáltam.

Nem hallottatok esetleg az MSI video capture filterrõl? MSI-ék persze nem tudják mi az :( .

 

Viszont valamit találtam egy fórumon. Azt írták, hogy a Vista telepítésekor nem mindig rakja fel (?) jól (??)

a video filtereket ezért jöhetnek a kamerákkal kapcsolat videofilter hibaüzenetek. Itt XP-rõl nem volt szó.

Ilyen tényleg lehetséges? Bár Bill Gates is multimilliárdos lett, úgyhogy lehet.

Valaki okos mondjon már valamit erre.

És hogyan lehet pótolni?

Lehet, hogy a windows telepítõlemez javítás opciója, vagy a rendszer újrahúzása a megoldás?

 

 

Azért még megpróbálom azt is elõbb, amit máshol írtak, hogy a VGA driverfrissítés megoldja a problémát.

 

Bocs, hogy hosszan írtam a nagy semmirõl, de az biztos, hogy a neten elérhetõ megoldások semmit nem érnek, csak azt nem tudom, ha valaki megoldotta, hogy valahogy "mukodjon" a kamerája, akkor mér nem írja be, hogy mi volt a megoldás?

 

No akkor pá, és elõre köszönöm a segítséget, ha valaki esetleg tudna valamit errõl a mágikus MSI video capture filterrõl.

 

T

 

 

Link to comment
Share on other sites

Aniko1111

Sziasztok!

 

Valóban igaz, hogyha megvan a megoldás, akkor legalább a kérdéshez is írjuk fel....

 

Nos: Nálam volt olyan kedves a bolt, hogy megnézte a gépet, persze fizetni kellett, de legalább mûködik.

A válasz valóban összeakadás. Bármi, ami cam-ot használ lehet a hiba okozója. Nálam pl a google rakott fel egy cam kezelõ valamit és azt szedték le és így már mûködött a dolog. (A google kijött egy online skype-hoz hasonló szolgáltatással, azt raktam én fel és azzal akadt össze. Hogy a google-ben most ezzel a szolgáltatással mi lett nem is néztem nem is használtam, úgyhogy nem fontos)

 

Nálam legalábbis ez volt a hiba oka.

 

Ha esetleg kell a bolt neve, megmondom priviben, esetleg be lehet vinni a Te géped is.

 

Üdv

Anikó

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...