Jump to content
GSForum - Segélyvonal

Firefox nem tölti be szkriptbõl a CSS-t


arpsoft
 Share

Recommended Posts

arpsoft

Szervusztok!

 

Nagyon szégyellem magam, két dolog miatt:

1. nem emlékszem mikor toltam ide az arcom utoljára. :upsz:

2. nem bírom rávenni a Firefoxot (se 2 se 3) hogy egy oldalon, amit egy foxisapi ad vissza betöltse a helyi hálózatról a css-t és a képeket.

 

Kicsit részletesebben:

van egy kereső szolgáltatás egy helyi hálózaton tárolt dokumentációs rendszerhez. Ennek az alapja az MS Indexing Server, valamint egy foxpro-ban megírt foxisapi kiszolgáló, ami a szerver adatbázisát lekérdezi.

Vannak előre elkészített sablon válasz html állományok, amiben a megfelelő részeket kicseréljük a találatokkal. Ezek az állományok gond nélkül megnyílnak a Firefoxban, css-el képekkel együtt.

 

De! Ha az oldal a foxisapi-n keresztül érkezik válaszként a keresési form 'action'-re adott válaszként, akkor nincs css és nincs kép.

Ha a visszaadtott oldal forrását elmentem html-be, és direktbe megnyitom, akkor megint van css és kép.

 

A hibakonzolon a következő van:

Biztonsági hiba: http://egyikszerver/dll/foxisapi.dll/search.search.latest_d helyen lévő tartalom nem töltheti be vagy hivatkozhatja file://///másikszerver/999-Objekte-Objects-Elemek/form.css-t.

 

További infók:

a két szervert nem lehet egyesíteni

a css-t és a képeket tartalmazó fájlokat nem kívánjuk áthelyezni

a "másikszerver"-en nincs web kiszolgáló, a html-ben csak helyi hálózati azaz file:/// hivatkozásokra van lehetőség

IE alatt semmi probléma

 

Már átnéztem egy csomó beállítást, de egyik sem volt hatásos.

Tud valaki segíteni esetleg?

 

Köszi!

Link to comment
Share on other sites

arpsoft

Nos, megtaláltam a megoldást.

A prefs.js-be kellett belerakni pár sort, ami megengedi a lokális hálózatról származó adatok betöltését:

 

user_pref("capability.policy.policynames", "localfilelinks");

user_pref("capability.policy.localfilelinks.sites", http://192.168.50.53");

user_pref("capability.policy.localfilelinks.checkloaduri.enabled, "allAccess");

 

 

Köszönöm mindenkinek, aki gondolkodott rajta.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...