Jump to content
Pjotr

Memtest86+

Recommended Posts

Pjotr

A programot a http://www.memtest.org/ címről tudjuk letölteni, válasszuk a Download - Pre-Compiled Bootable ISO (.gz)-t a letöltéseknél (Downloads). Töltsük le, csomagoljuk a letöltött állományt (pl.: Total Commander-rel, WinRAR-ral), aztán az így kapott ISO fájlt írjuk ki. (CD-író alkalmazásokban Lemezkép kiírása vagy hasonló menüt keressünk!) hagyjuk a lemezt bent az írónkban! Ha van otthon Linux CD-nk, akkor örülhetünk, mert azokon általában megtalálható a program, nem kell vesződnünk az írással (persze a memtest verziójára figyeljünk, minél újabb, annál jobb).

 

Ezután indítsuk újra a számítógépünket, lépjünk be a BIOS-ba, és ellenőrizzük, hogy az elsődleges booteszköz CD-re van-e állítva, ha nem így lenne, állítsuk meg, majd a BIOS-ból való kilépéskor mentsük a beállításokat. Ha ennek ellenére sem tudunk bootolni CD-ről, akkor próbálkozzunk másik alaplapi csatlakozóra csatlakoztatott optikai meghajtóval, vagy írjuk ki ismét a lemezünket, mert lehet, hogy azzal van a baj.

 

Ha sikerült bootolni róla, akkor nagy kékséget kell látnunk mindenféle információval. Nem kell állítanunk semmit, csak hagyjuk futni a programot. Mindenképpen több órán át (akár 1 napon keresztül) futtassuk a memtest-et, hiszen minél nagyobb memóriával rendelkezik a számítógépünk, annál több időre van szükség az ellenőrzéséhez, nem is beszélve a memóriák sebességéről.

 

Ha már az elején elkezdődik a hibák listázása (errors), akkor leállíthatjuk a programot, mert valami gubanc van a memóriák körül. Ha több modul van a gépben, kezdjük el őket egyesével ellenőrizni. Ha így is hibásnak bizonyul minden memória, akkor kérjünk kölcsön legalább 1 modult, így is ellenőrizzük a gépünket, mert lehet, hogy az alaplappal nincs minden rendben. Ha így is hibázik, akkor van esély arra, hogy az alaplap hibás, illetve, hogy a kölcsönkért memória sem működik megfelelően benne, nem támogatott. Esetleg egy BIOS-resetet meg lehet próbálni.

Ha többcsatornás üzemben mennek, akkor ki kell próbálni single channel-ben a modulokat, hátha!

Előfordul az is, hogy csupán az érintkezők szennyezettek a memóriákon, illetve az alaplapon. Tisztítsuk meg őket (papír).

Edited by Pjotr

Share this post


Link to post
Share on other sites
gpetike

Szia!

 

Segítséget szeretnék kérni. Nekem sehogy sem akar indulni CD-rõl. Vettem kislemezt, de elakadtam, mert letöltöttem arról az oldalrõl ezt "Download - Pre-Compiled package for Floppy (DOS - Win)" és nem tudom hogyan tovább. Tudnál nekem segíteni? Köszönöm.

 

Szia,

Peti

Share this post


Link to post
Share on other sites
sz.jános

Ha kislemezre, azaz floppyra akarod kiírni, akkor töltsd le pl. ezt a progit, vagy bármilyen másik neked tetsző memtest86+, ami floppy.zip végződésű, majd

- csomagold ki

- az install MS DOS-ra dupla klikk, ekkor megjelenik a C:\WINDOWS\system32\cmd.exe ablak ahol az

- "Enter target diskette drive:_" felirat után a villogó kurzornál beírod annak a meghajtónak a betűjelét (általában A ) amibe betetted a floppyt, majd Enter-t nyomsz. Ekkor megírja a foppyt.

Természetesen a floppynak formázottnak (MS DOS rendszerindító lemez) kell lenni.

 

Ha mindez kész, akkor beteszed a floppyt a meghajtóba és újraindítod a gépet, a többit a monitoron láthatod.

 

;)

Share this post


Link to post
Share on other sites
gpetike

Köszönöm szépen a segítséget.

 

Szia,

Peti

Share this post


Link to post
Share on other sites
First Officer

Sziasztok,

 

memóriateszttel kapcsolatos a kérdésem. Tudna valaki válaszolni arra, hogy a memtest86+ vagy a Windows 7 saját memóriatesztje csak a rendszermemóriát (RAM) vizsgálja avagy a grafikus kártya memóriáját is. A Windows 7 memtestje hibát jelez, de nem részletezi, hol a hiba. Én a graf. kártyára gyanakszom, ugyanis a mostani a harmadik konfiguráció ami ugyan azt a - kékhalálos - szindrómát mutatja, és csak a grafkártya ugyan az, minden mást cseréltem. Config: Abit Fatality FP-IN9 mobo, 4 GB Crucial Ballistix DDR2 mem, GeForce 8800GTX grafx, Windows 7 RC x64.

 

Köszönöm

 

FO

Share this post


Link to post
Share on other sites
First Officer

Frissítés!

 

memtest86+ segített kideríteni, hogy egy a 4 memóriamodul közül rettenetes állapotban van. A kérdésem így részben megválaszolva...

 

Mégsem a grafx...

Share this post


Link to post
Share on other sites
Csaba_#

Most csináltam tesztet a program legújabb 4.0-ás változatával, egy 128 Mb-os SD modulon, és 1 hibát talált miután végigfutott. Ezzel csak az a baj, hogy egy korábbi időben már egyszer lefuttattam a tesztet, és akkor viszont 7 hibát talált.

Azt nem hiszem, hogy azóta magától megjavult volna. Ezek után kicsit megrengett a bizalmam memtest86+ iránt. :( Esetleg köze lehet hozzá annak, hogy az adott alaplap integrált VGA-ját használtam mindkét időpontban?

Share this post


Link to post
Share on other sites
Pjotr

Lehet köze hozzá (videokártyának elkülönített memóriát nem vizsgálja), de egyszeri végigfuttatás egyébként sem teszt. ;)

Share this post


Link to post
Share on other sites
Csaba_#

Ezt úgy kell érteni, hogy az integrált VGA fizikailag nem mindíg ugyan azt a területet foglalja le?

Már egyetlen teszt is marha sok idõ. Mennyi az a tesztet kell futtatni, ha valaki biztsra akar menni?

Share this post


Link to post
Share on other sites
Fujitsu

Szerintem nem kell többször vizsgálni, csak egyszer, de akkor sokáig. A képernyő jobb felső részén kijelzi, hogy épp hol, mit, mennyit vizsgál, ha ott egy párszor végigfut a csík, az már nagyjából elegendő ahhoz, hogy el lehessen dönteni, van-e probléma a memóriákkal. Legalábbis nagyon-nagyon ritka, hogy mondjuk kétszeri végigfutás alatt ne jelezzen legalább egyszer egy hibát, ha problémás a RAM. A kijelzett hibák száma egyébként nem feltétlenül utal a memória hibájára.

Share this post


Link to post
Share on other sites
KGigi

Mennyi az esélye egy fals negatívnak (azaz hogy jónak jelzi a memóriákat, de mégsem azok)? Tegnap este meghülyült az Avast! a laptopomon, azóta változatos hibaüzenetekkel (bad pool caller, bad pool header, memory management, threading valami) kékhalálozik. Helyreállítottam a rendszert, de random időközönként most is ezt csinálja. Ekkor terelődött a gyanúm a memóriákra. Egész éjjel futott a teszt, legalább 5-6 alkalommal körbe is ért, nem fagyott le. A Windows saját diagnosztikája sem jelzett hibát. Ubuntu alól kiolvastam a merevlemez SMART-ját, illetve stressztesztet is csináltam, ezekkel sem volt semmi probléma. Scandisk is volt. Viszont egyszer az Ubuntu is lefagyott, ezért teszem fel a kérdésemet. Újratelepíteni nem akarok, mert a hétvégén repül a Windows és az Ubuntu is, és Debian, illetve Vmware-es Windows kerül a helyükre, mert végre szereztem memóriát a gépbe. Illetve ez most feltételes módba került, mert nem tudom, rendben van-e a gép.

Share this post


Link to post
Share on other sites
Fujitsu

Ha az első két kör alatt nem dob hibát, 2% alatti az esélye, hogy hibás. Úgyhogy ott valami más gond lesz. Abból, amit leírtál, amúgy sem következtetnék elsősorban memóriaproblémára (legalábbis a bad pool kezdetűek nem erre utalnak).

Share this post


Link to post
Share on other sites
KGigi

A bad pool szinte mindig driverhiba. Viszont a memory management gyanús lett. Ami igazán elgondolkodtatott, az a linux fagyása, ami egyáltalán nem megszokott, habár tudom, hogy bugos az Ubuntu energiagazdálkodása, így ez is okozhatta a problémát. Csak furcsa volt ez az együttállás. Szerintem is baromi kevés az esélye a hardverhibának, valószínűleg megpróbálom a telepítést. Ha egy Debian lefagy, az már egészen biztosan nem normális. :)

Share this post


Link to post
Share on other sites
Fujitsu

Én nem hardverhibát írtam, hanem memóriaproblémát. Magával a memóriával szerintem nincs gond, de ettõl még egyáltalán nincs kizárva, hogy valamelyik hardverrel gond van, sõt. Önmagától a Windows sohasem kékhalálozik, és a mai Windowsok már szoftverhibától sem nagyon szoktak. Az Ubuntut nem ismerem ennyire, de az, hogy a két rendszer egyszerre produkál hibajelenségeket, nem lehet véletlen. :(

Share this post


Link to post
Share on other sites
KGigi

Probléma megoldva. A Debian még azelőtt szétfagyott, hogy fel tudtam volna tenni a grafikus felületet. (A telepítő ellenben simán végigment.) Otthagytam letölteni a KDE-t, mire visszamentem, üres fekete képernyő (csak a háttérvilágítás ment) fogadott és semmire nem reagált a gép.

 

A memóriák (egyébként 667 MHz-es CL5-ös 2 GB-os Geil modulok) kb. két hete bent vannak, eddig nem volt gond. Merrefelé induljak? Mivel ez egy laptop, a memória kivételével mással nem nagyon tudok játszani. És mivel a memtest nem dob hibát, a fagyás pedig teljesen véletlenszerűen jelentkezik, ezzel sem megyek semmire.

 

Az a furcsa, hogy a memtest nem csak hogy nem dobott hibát, de gond nélkül elfutott magában nyolc órán át, akkor nem volt fagyás. HDD-hiba esetén viszont szerintem nem kéne csontra fagynia a rendszernek.

Share this post


Link to post
Share on other sites
Fujitsu

Úgy értsem ezt, hogy a memóriák utólag kerültek bele a gépbe? Vagy egy ideig mûködtek probléma nélkül? Ja, ugye nem integrált memóriavezérlõs a processzorod? (Csak mert akkor a GeIL nem volt jó ötlet.)

 

Egyébként a HDD hibáját sem valószínûsítem, elviekben az sem okoz ilyesmit. Ez valami komolyabb lesz, sajnos. Alaplap vagy processzor, tápáramkör, videovezérlõ – bármelyik lehet. Még a hõmérsékleteket, az órajeleket és a feszültségeket is ellenõrizném (meg úgy mindent a BIOS-ban), bár ez is vakvágánynak tûnik.

Share this post


Link to post
Share on other sites
Pjotr

A memtest nem ellenõrzi azt a memóriaterületet, ami a GPU-nak van kiadva, simán elképzelhetõ, hogy rossz(ak) a modul(ok).

Share this post


Link to post
Share on other sites
KGigi

A gépben csak két giga memória volt, ami mostanra kevés lett. Így vettem bele egy Geil 4 GB-os dual channel kitet. Sajnos csak ebből volt 667 MHz-es kit. Előtte nem csinált ilyet, és azóta is ment így egy ideje.

 

A frissen telepített rendszer is folyamatosan összeomlik. Most legutoljára csippant is egyet. Megpróbáljam visszatenni a régi modulokat? Az a baj, hogy nem tudom hogyan tesztelni, véletlenszerű a fagyás. Valamikor órákig is megy. Viszont néha gyönyörű segmentation fault-okat dob, szóval szinte biztos, hogy memória. Egyszerűen vigyem vissza az új modulokat?

Share this post


Link to post
Share on other sites
Fujitsu

De hiszen azt írtad, hogy eddig nem volt velük gond... Amúgy ahhoz nagyon pechesnek kell lenni, hogy pont a grafikus vezérlõ által lefoglalt területen legyen a gebasz, azon kívül meg semmi. (Már ha egyáltalán integrált GPU-ról beszélünk, ugyebár. :hááát: )

Én inkább vezérlõ- vagy processzorhibára gyanakodnék, bár valamit akkor is kéne nyögnie a Memtestnek. Bár, ha random jön elõ a probléma (tehát instabil), akkor nem feltétlenül... :hmm: Nem is tudom, mit agonizálunk még itt ezen: kapd ki a memóriákat, variálj velük, nézd meg, mit reagál; lesd meg a BIOS-t (mintha ezt már javasoltam is volna), a hõmérsékleteket stb., elvégre nem vagy már kezdõ. Aztán ha van fejlemény, referálj róla.

Share this post


Link to post
Share on other sites
KGigi

A gép egy Toshiba Satellite Pro A300 15T, szóval egy gagyi integrált Intel VGA van benne. Mindjárt szétkapom a gépet, csak eddig szoftveres oldalról próbálkoztam.

Share this post


Link to post
Share on other sites
Fujitsu

Van még rajta garancia? Amúgy van ám nekik jó kis support fórumuk is, esetleg még ott is lehet érdeklõdni, ha már minden kötél szakad.

Share this post


Link to post
Share on other sites
KGigi

Nem, szeptember óta nem garanciális. :nem: Most egy órája van talpon a régi modulokkal probléma nélkül.

Share this post


Link to post
Share on other sites
KGigi

Ma reggel nyolc óta megy folyamatosan hiba nélkül, SSH-n idõnként ránéztem egyetemrõl. Szóval valamelyik modul rossz. :S Köszi a segítséget!

Share this post


Link to post
Share on other sites
Garono

Lehetséges, hogy a Memtest86+ által kiírt memória sávszélesség köszönõ viszonyban sincs a valós sávszéllel? :pislog: 2 db DDR2 800 MHz / PC2-6400-es modulra 4108 MB/s-ot ír. Közben pl. az AIDA64 6328 MB/s-ot ír, ami már elég jól közelíti az elméleti 6400 MB/s-os határt. :hááát:

Share this post


Link to post
Share on other sites
Asztalos

Bocsi ha nem jó helyen kérdezek... :upsz: Szóval... Volt 2GB ram a gépemben és most vettem hozzá még kettõt,de a Windows 7 vagy lefagy vagy kékhal még mielõtt minden (kötelezõ)progi elindulna. :dühös: A Memtest 4.2 nem jelzett hibát. Csökkentett módban elindul a gép. Még arra gondoltam, hogy nem-e az 5GB free space kevés a C meghajtón !?

Edited by KGigi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...