Jump to content

Toljátok a bucira a sapit! Éljen a GSF hagyomány! :D

oromon

Cisco topik

Recommended Posts

oromon

Sziasztok!

 

Van egy olyan gondom, hogy a suliban meg kellene mozdítani a hálózatot költözés után. Minden be vagyon kábelezve, a Sulinet hozta át a dobozt, a szervereket már mi. Van egy swich, egy router valamint egy modem. A modem ethernet portja a router ethernet portjába jön, a router 1sõ kimenõ portjával van a swich 24-ese (utolsója) kötve. Kérdés, hogy csillagpontos háló esetén hova csatlakoztassam magát a servert? A "management port" már a helyén van.

Share this post


Link to post
Share on other sites
Shia-ko

Igazából teljesen mindegy, hogy hova rakod, és megszokásból a routerbe kötném.

Share this post


Link to post
Share on other sites
arpsoft

Én meg a switch-be, mivel csak így lehet kihasználni a switch kapcsolási teljesítményét! A router 100Mbit-es kapcsolattal van a switch-hez kötve. Ezen osztozik mindenki, aki adatot forgalmaz a router (Internet és a router portjaira kötött eszközök) és a switch között. Tehát, ha a szerver a routeren van, a 100Mbit nem lesz meg teljes egészében, míg ha a switchbe van dugva, akkor a switch - okos jószág lévén - a szerver felé csak a neki szánt kéréseket adja. Ha nem is számottevő a különbség, jobb lesz a szervered elérése.

Share this post


Link to post
Share on other sites
dflame

Ha már sulinet, akkor megosztom veletek egy nem oly régi tapasztalásom. Volt szerencsém karbantartani egy sulinetes hálózatot, hát mit mondjak, érdekes struktúrát sikerült összekalapálniuk a srácoknak. ADSL modem után Cisco router, majd 24 portos Cisco switch 24-es portja. Switch 1-es portja a szerverbe, szerverbõl egy HP 16 portos hub-ba és a hub-ból a 12 gépes hálózathoz. Szép és így legalább el tudtak adni egy hub-ot is 120 eFt-ért. Ha mindenhol ezen szisztéma szerint építkeznek, akkor ez baromi jó üzlet. Ott az az 1 Gb-es, gyönyörû és baromi drága Cisco switch, ráadásul menedzselhetõ és 22 portja kihasználatlanul kong, a háló pedig természetesen lassú. Röhely...

Share this post


Link to post
Share on other sites
oromon

Igen, felhívtam a köcsögöket, és a következõképp néz ki a rendszer:

Telindus DSL-modem -> Cisco Router -> Cisco 24 portos 10/100/1000 swich 24-es portja (figyelik ám, hogy oda kötöd-e). Ineen kötheted úgy, hogy a privát szegmensbe a servert, a publikusba a munkaállomásokat, a védettbe pedig a vezetõk gépeit, vagy a nagyon titkos cuccokat. Felettébb rugalmas. Mivel már megvolt a saját bind démonom bekonfigolva, ezért az egészet egy külön swichre kötöttem... tehát a szerver belsõ kártyája megyen egy másik 10/100/1000-es swichbe (surecom), onnan meg a hálózat...

 

És itt merül fel a következõ gond:

 

Az iroda és a tanári öt-öt gépét egy-egy egyenként 8-portos surecom swichel kötöttem a hálózathoz.

Hardveresen látják egymást - legalábbis a kontroll-ledek szerint, viszont szoftveres kapcsolat nincs...

 

Ennek vajh mi lehet az oka?

Share this post


Link to post
Share on other sites
arpsoft

Tudom, hogy hülye kérdés, de a színsorrend jó a kábelekben?

Aztán még lehet ip beállítási probléma is. Vagy azt a szervertõl kapják?

Share this post


Link to post
Share on other sites
oromon

Nem hülye a kérdés, buktam már el ilyenen. A swich felismeri a kábeltípusokat, sõt helyreállítja a polaritáshibákat is (persze 1 hiba mélységig) , de a kábelek tesztelve vannak, illetve a két swich crosslink kábellel van összekötve. (távolságuk 25 m ) d úgy tudom, ez nem számít (100 m-ig)

 

A serveren bind fut, tehát a dns-t õ osztja ki, az ip-k megyegyeznek a célgépen és a bind-ben is. (bind= linuxos dns-server)

 

Azok a munkaállomások, amelyek közvetlenül a rackes swichbe mennek, látnk mindent, csak ezzel a 6 mukaállomással van gond....

 

Nem lehet-e az, hogy a swich itt egy gateway...? (nem... csak már mindent kipróbáltam, ami eszembe jutott, és kezdem azt hinni, hogy teljesen hüle vagyok)

 

 

Köszi:

 

G

Share this post


Link to post
Share on other sites
arpsoft

Na szóval akkor ugye az van, hogy jön a net, az be a cisco-ba, onnan megy egy madzag a szerverbe. A szerverbõl megy egy másik madzag az egyik Surecom-ba, onnan gépekbe illetve a többi kicsi switch-be, onnan meg a gépekbe.

Ha így van és nem látják egymást a gépek, akkor ott valami nagy gáz lehet. Legalább az egy switchen lévõ gépeknek muszáj lenne látni egymást.

A szerveren kívül nincs más összeköttetés a cisco rendszer és a surecom rendszer között? Nem alakulhat ki háromszög?

Share this post


Link to post
Share on other sites
Greene

A ciscoban kéne megnézni a portokat, mondjuk egy "show interface" vagy "show port" paranccsal, mert ott látni lehet az adott portra vonatkozóan mindent.

Share this post


Link to post
Share on other sites
arpsoft

Greene: nekem az jött le, hogy a cisco-ra csak a szerver egyik kártyája van kötve. Ergo a hálózat többi részéhez, ami a szerver másik kártyáján lóg elvileg nem sok köze van. Persze ettõl még bármi lehetséges.

Share this post


Link to post
Share on other sites
oromon

Haromszog nem alakulhatott ki, mar a ciscot is bekonfigoltam... koszonom, Tarja :-)

 

A 16-os swich lakoi lattak egymast a kezdetektol, a nagy gond az, hogy a 15m-rel arrebb levo 8-as swich lakoi nem latjak a 16-os testver lakoit. Egymast igen, de a swichen tul nem. A kontroll-ledek jelzik a kapcsolatot... az lehet-e hiba, hogy az egyik kabelnel (harom helyen toldva van a kabel, mire leer a 16-osbol a 8-asba)rossz a szinsorrrend, s bar egyenaram szempontjabol jo, de adatatvitelbol beteg? (mellesleg mi ennek az oka?) Mindenhol mashol megy a halo, itt van az egyetlen gond.

 

ui.: elnezest az angol billentyuzetert!

 

udv:

 

G

Share this post


Link to post
Share on other sites
arpsoft

Igen, ez lehet a probléma, sõt, minden valószínûség szerint ez a probléma.

Share this post


Link to post
Share on other sites
oromon

És mi ennek az oka?

Share this post


Link to post
Share on other sites
arpsoft

Az, hogy a toldásoknál összekevered a sodrási rendet és leromlik a nagyfrekvenciás teljesítõképessége a kábelnek. Ezért nem szokás toldani a csavart érpáras madzagokat. Egyébként, ha beraksz egy-egy kicsi switch-et a toldásokba, akkor mennie kellene.

A kontrol ledek akkor is égnek, ha egyenáramúlag jó a madzag.

Share this post


Link to post
Share on other sites
oromon

eééértem.

 

Köszönöm, behúztam EGY kábelt a csatornába, arra kötöttem, természetesen azonnal helyreállt az õsi rend.

 

Mégegyszer köszönöm!

Share this post


Link to post
Share on other sites
Gr3nT

Bocsi hogy regem első dolgát egy új topic nyitással kezdem, de remélhetőleg elnézik nekem.

Cisco routerek beállításával kevesen foglalkoznak nyiltan a fórumokban, amit meg találtam és elolvasva felfogtam messze nem kielégítő számomra. Rendelkezem némi képesítéssel, fel is fogok sok dolgot, de ehhez segítség kellene.

 

Cisco 871-es routerrel szeretnék majdan kapcsolódni egyik mobilszolgáltatónkkal VPN-el.

 

Az internet elérése jelenleg fix IP-s ADSL-el történik. Itt jön az első problémám.

 

SDM-el szeretném konfigolni a routert (ezt legalább megértem), sajnos a konzolhoz kicsi kacsa vagyok még.

 

Első lépés:

Tehát hogyan hozzam rajta létre az internet kapcsolatot.(username és PW van az ADSL-hez).

 

Próbálkoztam már de jel nem jön át, tehát vagy nem kapcsolódik a router, vagy a tűzfal megfogja. Vagy tök béna vagyok és egy tengizi rádióadót próbálok elérni!

 

Hogyan kell akkor? Esetleg valakinek akad hasonló cucca és az SDM képernyőről képeket tudna adni. Hogy lássam mi lenne a helyes.

 

Sokat ültem előtte, olvasgattam a fórumokat angolt és magyart is. De mindenhol konzolt használnak.

 

Ha még sem menne kénytelen leszek szakit hívni persze pénztárca bánja, de én előtte megpróbálnám magam megérteni a feladatot.

 

Köszi szépen türelmesen várom a válaszokat.

Share this post


Link to post
Share on other sites
Greene

Én is konzolt használok (mint minden normális Cisco-s ember), és írtam magamnak egy egész tűrhető kis ADSL-es konfigot (831-es Ciscora; 1WAN ethernet, 4LAN fastethernet). A routeok még nincsenek rendesen beállítva de azért teljesen jól megy (na jó még van rajta csiszolnivaló, meg felesleges dolog ami nem kell, van viszont dhcp pool amiből osztok a helyi hálóra ip-t. VPN nincs):

 

Annyit kell ezzel tenni, hogy bejelentkezel konzolon, enable paranccsal átváltasz a megfelelő módba, majd a configure terminal parancsot kiadod, és becopyzod ezt a konfigot (persze a jelszavak felhasználónevek átírása után). Majd kiadod a copy running-config startup-config parancsot. Ezzel kész is lenne. De még mielött beírod a copy-t, minden portra a no shutdown parancsot ki kell adnod illetve a LAN-os interface-eket be kell állítanod.

 

Amúgy a fix ip-s ADSL úgy néz ki, hogy mindig ugyanazt az IP-t kapod a radius szervertől. Tehát nem kell beírnod fixen. Ez a konfig PAP és CHAP autentikációt is tud, így maximálisan szolgáltató kompatibilis. Habár a CHAP-ot használják a legtöbben.

 

Íme:

 

version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname MyCisco
!
boot-start-marker
boot-end-marker
!
enable secret jelszo
!
username juzer privilege 15 secret jelszo
aaa new-model
aaa authentication login default local
aaa authorization exec default local
aaa session-id common
ip subnet-zero
ip dhcp excluded-address 192.168.1.1 192.168.1.20
ip dhcp excluded-address 192.168.1.31 192.168.1.254
!
ip dhcp pool mypool
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server dns szerver1 dns szerver2
!
!
ip name-server nevszerver ip-je
ip name-server nevszerver ip-je
ip audit notify log
ip audit po max-events 100
ip ssh break-string
vpdn-group 1
request-dialin
  protocol pppoe
!
no ftp-server write-enable
no scripting tcl init
no scripting tcl encdir
!
!
!
no crypto isakmp enable
!
!
!
!
interface Ethernet0
description LAN side
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
no cdp enable
hold-queue 32 in
hold-queue 100 out
!
interface Ethernet1
description WAN side PPPoE
no ip address
duplex auto
pppoe enable
pppoe-client dial-pool-number 1 dial-on-demand
no cdp enable
!
interface FastEthernet1
description Greene notebook
no ip address
duplex auto
speed 100
!
interface FastEthernet2
no ip address
duplex auto
speed 100
!
interface FastEthernet3
no ip address
duplex auto
speed 10
!
interface FastEthernet4
description Trunk
no ip address
duplex auto
speed 10
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap chap callin
ppp chap hostname adslusernev@szolgaltato.hu
ppp chap password jelszo
ppp pap sent-username adslusernev@szolgaltato.hu password jelszo
ppp ipcp dns request
!
ip nat translation timeout 600
ip nat translation tcp-timeout 600
ip nat inside source list 10 interface Dialer1 overload
ip nat inside source list 102 interface Dialer1 overload
ip nat inside source static tcp 192.168.1.21 80 interface Ethernet1 80
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
!
!
access-list 10 permit any
access-list 23 permit 0.0.0.0 255.255.255.0
access-list 102 permit ip 0.0.0.0 255.255.255.0 any
dialer-list 1 protocol ip permit
snmp-server community snmpjelszo RO
snmp-server enable traps tty
no cdp run
!
control-plane
!
banner motd ^C-Bejelentkezeskor megjeleno uzenet^C
!
line con 0
no modem enable
transport preferred all
transport output all
stopbits 1
line aux 0
transport preferred all
transport output all
stopbits 1
line vty 0 4
transport preferred telnet
transport input telnet
transport output none
!
scheduler max-task-time 5000
!
end

Share this post


Link to post
Share on other sites
Gr3nT

Köszi, amint hozzáférek a cuccoshoz megpróbálom és tovább dumálhatunk errõl.

Share this post


Link to post
Share on other sites
Gr3nT

Jó, itt a cuccos mellettem. Lépésrõl lépésre megmondanád hogyan kell a konzolt úgy beállítanom hogy bemásolva ez a config fusson nállam is?

 

 

Share this post


Link to post
Share on other sites
Gr3nT

Nemigazán Mûködik a dolog. Hahóóóó!

Share this post


Link to post
Share on other sites
Gr3nT

Egy probléma ha ip-t szeretnék hozzáadni egy ethernet porthoz akkor mindig ezt az üzit dobja ki.

 

% IP addresses may not be configured on L2 links.

 

Mi a teendõm? Nemvágom.

 

 

Share this post


Link to post
Share on other sites
Greene

Valószínűleg az a baja, hogy a switch rész ugye Layer2-n megy ami azt jelenti, hogy IP címe nincs. Ezért látod az én konfigomat is, és ott sincs a Fast etherneteknek IP címük. Egyedül két portnak lesz saját ip-je. Az egyik amire az ADSL modemet kötötted, a másik az egy félig-meddig virtuális interface. De az ADSL-es interface is automatán kapja az IP-t.

Share this post


Link to post
Share on other sites
Gr3nT

Hát megküzdöttem a dologgal, meséljem? :D

Addig addig kutakodtam míg találtam sok mindent. Elég új cuccos még ez a 871-es router.

Próbálkoztam így meg úgy. Sikerült törölnöm még az IOS-t is. De nagynehezen sikerült leszednem egy uj IOS-t. Feltelepítettem, a routerhez adnak CD-t azon rajta van a default Cisco config, ezt is feltettem. Így most van újra egy mûködõ képes cisco 871-es routerem :D

Halomnyi linket szedtem össze mindenhonnan.

 

És ismét ott állok hogy hogyan tovább.

Share this post


Link to post
Share on other sites
Greene

Be kéne állítanod a dolgokat akkor egymás után. Először mindent ami nem interface. (lásd az én konfigomat)

 

Egyébként a konfigurálás így működik:

- Belépsz, és kapsz egy promptot amiben a hostnév szerepel, és egy kacsacsőr. Ez az alap mód, sokmindenre nem jó ezért be kell írni, hogy "enable" (ha meg van adva enable password vagy enable secret a konfigban akkor kér majd egy jelszót).

- Enable módban a prompt után egy kettőskereszt van. Ilyenkor lehet megnézni az éppen futó konfigot ("show running-config"), és ha el akarod menteni akkor elmentheted ("copy running-config startup-config"). A "show run" (rövidíthetsz is felismeri a cisco) parancsnál meg tudod nézni az összes interface-edet (persze a virtuálisakat te hozod létre azzal, hogy konfigurálod őket). A show parancs után egy szünet majd egy kérdőjel listázza az összes elérhető dolgot amit show-val meg tudsz nézni. A sima kérdőjel listázza az összes parancsot.

- Van olyan parancs amivel egy-két globális szolgáltatást tudsz beállítani (pl. "service password encyption"). Ehhez enable módban elöbb a "configure terminal" parancsot kell kiadnod. Ilyenkor a prompt megváltozik, a kettőskereszt mögé kerül zárójelben az, hogy config.

- Még innen is mehetünk egy szinttel beljebb, ha a "configure" promptnál beírjuk egy interface nevét. Pl: ethernet0 vagy akár ethernet1, fastethernet4, dialer1. Esetleg con0 vty0 4 (egyszerre mind az öt virtuális terminál konfigurálása, ez alkalmazható tömegesen bármilyen interface-re). (prompt vége interface-nél: config-if, vty, aux és egyéb portoknál: config-line)

Neked ethernet interface-eid vannak, amiken egy plusz dolgot még meg kell adnod. A (config-if) promptnál "no shutdown" paranccsal életre keltheted a portot. A "shutdown" pedig lekapcsolja. Ez az egész Cisco filozófiára igaz. Ha valamit mondjuk elrontottál, akkor add ki ugyanazt a parancsot, de tégy elé egy "no" szócskát és máris nem lesz ott.

Nézd meg a konfigot, ahol interface van ott az azt követő adatok (config-if) promptban lettek megadva.

Fontos: Ha végeztél egy adott interface konfigurálásával akkor az end és az exit paranccsokkal tudsz kilépni. Az egyik teljesen kilép enable módba, a másik csak egy szintet vissza. Ne felejts menteni.

Tehát a konfigomból látszik, hogy ha beilleszted így simán (mert enable módban be lehet így másolni egy az egyben), akkor még a "no shutdown"-t ki kell add a portokra. Ha jó minden (persze a portok mások lesznek nálad) akkor pedig elmentheted.

 

Nagyon egyszerű példa: enable módban beírod, hogy "conf t" (ez a configure terminal rövidítése) majd config módban beírod, hogy "hostname AzEnCiscom". Egyből megváltozik a promptnál a hostnév.

Share this post


Link to post
Share on other sites
Gr3nT

Nagyon köszi hogy leírtad.

 

Képzeld ez alatt a pár nap alatt ezeket sikerült feltérképeznem és találtam a parancsokhoz elég jó megfelelõ weboldalt.

 

Mostmár csak be kellene élesíteni, de az internet kapcsolat az istennek sem akar létrejönni.

 

Annélkül meg a router egy doboz csak ami szépen világít :D

 

De még jelentkezem!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...