Jump to content
GSForum - Segélyvonal

Segítség karakteres felülethez (kezdõknek)


Laczy75
 Share

Recommended Posts

Laczy75

Üdv!

 

Adott egy kezdõ linuxos, van egy gép amire a legújabb fedora van telepítve (karakteres felület). viszont nem látja a háló kártyát nincs rajta mc.

A célt már kitüztem hogy merre induljak el, viszont ahogy utána néztem úgy nem jutok elöbbre.

Szerettem volna feltelepíteni a hálókártyát találtam hozzá drivert letöltöttem a netrõl egy floppyra de nem tudom bemásolni.

Probálom mountolni a floppyt ( mount -a /dev/fd0 /mnt/floppy) de nem mûködik megnézi a floopyt de nem csatolja, azt írja hogy: you must specify the filesystem type

pedig ahogy a neten és a manban láttam a " -a " kapcsoló arra van hogy minden fáljrendszert feltegyen, de ugyan ez a helyzet a telepítõ cd-nél is.

szóval ezek után hogyan tudnám felrakni a hálokártya driver-t és az mc-t valamint még ki tudja mi kell majd.

 

segítséget elõre is köszi

 

Laczy

Link to comment
Share on other sites

Greene

mount /dev/fd0 /media/floppy -o rw,noauto,user,sync

 

Egyébként a /etc/fstab állományba célszerû lenne berakni valahogy így:

(A sok pontot azért raktam be, hogy elkülönüljenek az oszlopok)

 

/dev/fd0............/media/floppy......auto........rw,noauto,user,sync......0 0

 

Illetve meg kéne nézni neten, hogy milyen hálókártyád van, és keresni hozzá linuxos modult, mert a floppyn nem biztos, hogy lesz linuxos...

 

Az MC-t meg told fel:

yum install mc

Link to comment
Share on other sites

Laczy75

Sajnos így is ugyan az az üzenet, a file-ba még nem próbáltam beírni.

a hálókártya driver-ét direkt ehhez töltöttem le linuxhoz,

Link to comment
Share on other sites

Greene

mount /dev/fd0 /media/floppy -o rw,noauto,user,sync -t msdos

Vagy az msdos helyett vfat.

Lehet, hogy nem szereti a floppy vezérlõdet a kernel? :hááát:

Esetleg CDRW-re ha kiírod?

Link to comment
Share on other sites

Laczy75

Thenx ez így már mûködik sikerült a floppyt és a cd-t is mountolni.

viszont elakadtam az mc csomag telepítésével,

installáltam az rmpkey-t (rpm --import /mnt/cdrom/RPM-GPG-KEY) ami ha jól értemlmeztem a csomagokhoz kell, viszont sehogy sem tudom az mc.rpm-et telepíteni (sem az rpm -ivh mc.rpm sem az rpm -Uvh mc rpm nem jó) nem találja a fájlt, megnéztem a cdrom/fedora/rpms könyvtárban és tényleg nincs mc.rpm

viszont akkor hol lehet illetve ha nics mi van helyette?

Link to comment
Share on other sites

Laczy75
megnéztem a cdrom/fedora/rpms könyvtárban és tényleg nincs mc.rpm

viszont akkor hol lehet illetve ha nics mi van helyette?

Elnézést! :upsz:

 

Megtaláltam az mc-t a 4. lemezen és sikerült is felraknom. Az egyik lemezt kétszer néztem véletlenül, azért nem találtam

Link to comment
Share on other sites

Laczy75

Nos megint kérnék egy kis segítséget!

 

A hálókártya driver telepítésnél már az elsõ sor után elakadtam. A következõ instrukciókat találtam a neten:

step 1: download the driver from

rtl8139.c

 

step 2: compile:

The instruction for compiling the driver is include at the

end of the driver file. (run this instruction at

/usr/src/linux)

 

step 3: insert the driver as module:

insmod rtl8139.o

parameter can be added by adding options=..... behind the istrruction

0x16(bit 4):full duplex

bit 0-3 :default port

(run 'lsmod' to see if the module is inserted)

 

step 4: bind your card to an IP address

 

/sbin/ifconfig eth0 ${IPADDR} broadcast ${BROADCAST} netmask ${NETMASK}

(run 'netstat -i' to see if there is a interface 'ne0')

 

step 5: add your card to IP routing table, then add gateway also

your card:

/sbin/route add -net ${NETWORK} netmask ${NETMASK} eth0

(should be able to ping local network now)

gateway:

/sbin/route add default gw ${GATEWAY} netmask 0.0.0.0 metric 1

 

step 6: start inet deamon.

/usr/sbin/inetd

(you are on the network now)

 

*make sure that your kernel is built with network, fast_ethernet and module

support. Otherwise, you have to rebuild your kernel.

(1:go to /usr/src/linux directory

2:run 'make menuconfig' or 'make config'

3:mark the options list above.

4:exit and rebuild your kernel.

make dep;make clean;make zImage

the file 'zImage' will be at /usr/src/linux/arch/i386/boot/zImage

5:modify /etc/lilo.conf.(this file specify where kernel image is)

6:run 'lilo' )

 

You cna run 'netconfig' which will do step 4,5,6 for you. This will create

'/etc/rc.d/inet1' and 'inet2' files. These two files will run at boot time.

Then just add a line at the beginning of 'inet1'.

'insmod /your driver'path/rtl8139.o'

 

bemásoltam a filet ahova javasolta /usr/src/redhat (ez van azon a helyen valamint a kernel gondolom az nem az)

 

a mutatvány ott megbukik hogy az insmod rtl8139.o re hibaüzenetet ad.

no module found in object

insmod: error inserting 'rtl8139.o' : -1 invalid module format.

 

Nem értem hogy most mi a gond.

Link to comment
Share on other sites

aty

Nem azért a húszfillérért, de a Linux kernel kb. 3 éve tartalmaz támogatást a Realtek 8139es chipsetû kártyákhoz.

modprobe 8139too

8139+ chipsethez:

modprobe 8139cp

Link to comment
Share on other sites

Greene

Azt hiszem a 2.4-es kernellel volt csak gond a 8139-nél (vagy a 29-nél már nem emlékszem pontosan). De az már ugye "ezer" éves. Viszont a Debian Sarge még azzal telepítene ha hagynánk.

 

Amelyik modul bevált, annál berakhatod a modules-be, hogy mindig betöltse.

pl.:

echo 8139too >> /etc/modules

 

Ez most Fedora? Mert párhuzamosan több linux topic megy és össze leszek kavarodva. ;)

Link to comment
Share on other sites

aty

Az utolsó problémás disztró a Debian Woody volt talán a 2.4.20-as kernelével, ami nem ette meg azonnal ezt a kártyát. De már a Fedora 1 is 2.4.2x kernellel jött ki.

Link to comment
Share on other sites

Laczy75
Azt hiszem a 2.4-es kernellel volt csak gond a 8139-nél (vagy a 29-nél már nem emlékszem pontosan). De az már ugye "ezer" éves. Viszont a Debian Sarge még azzal telepítene ha hagynánk.

 

Amelyik modul bevált, annál berakhatod a modules-be, hogy mindig betöltse.

pl.:

echo 8139too >> /etc/modules

 

Ez most Fedora? Mert párhuzamosan több linux topic megy és össze leszek kavarodva. ;)

Igen fedora.

 

Most probálgatom amiket irtatok, szólok mire jutottam.

Link to comment
Share on other sites

Laczy75

Na sikerült tényleg bent volt csak nem tudtam hol keressem,

az lsmod-al megtudtam nézni és ott volt az új rtl3189too. Hát ez nem windows :)

 

Beállítóttam az ip-t most már mûködik.

 

Biztos fogok még kérdezni, most egyenlõre próbálgatok, ssh-t összehozni.

 

Köszönöm a segítséget.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...